Apple Messes Up USB 3.0 Audio Big Time

I'm a longtime Apple Mac user - my first machine was a Performa 6100. Every time Apple upgrades their systems or changes processors inevitably something gets "broken" and takes a generation or two or three (or never) to get fixed. Anyone who depended on the feature or compatibility that got deep-sixed laments on the Apple help boards and some clever person figures out a workaround, in most cases, but sometimes not.

AR-usbshit4.jpgWell, with the latest OS, El Capitan 10.11.1 combined with the new USB 3.0 port specs my number finally came up and a bug has bitten me (and many other audiophiles) on the butt. There's several long threads on the Apple help boards about the various audio devices hosed. Scanners also took a hit. Here's a partial list of all the devices that owners have had problems with, so far - Nuforce dac, Audioquest Dragonfly, SoundBlaster X7, Emotiva XDA-2, Audeze Deckard, Duet2, M-Audio M-Track Quad, Tascam US-1800, Avid MBox, MSB Analog Dac, Fast Track Ultra, Audio Kontrol 1, Northstar Dac 32, Meridian Explorer, Miyo, Bose Companion 5, Teac A-H01 DAC, ZOOM R16, Focusrite Scarlett 2i2, Native Instruments Traktor, Yamaha CD-S3000 DAC, and M-Audio  Keystudio 49i. I'm sure there are others.

With the latest OS, on my machines if you detach, jostle, or otherwise mess with the USB cable between your USB DAC and your computer (in my case mainly a Mac Pro desktop Titanium trashcan, and also a 13" 2015 MacBook Pro) it will drop, forget, and banish that DAC from your list of audio devices and it will not reappear until you institute the magic fix. What is the magic fix? Reboot your machine and your DAC will reappear on the list in the MIDI control window and you may select it as your dedicated sound output device just as you did the last time you had to reboot your Mac for the same reason...

AR-usbshit2.jpgThis bug makes it WAY harder to compare USB cables, DACs, or any other USB-connected audio device. If I change cables I must reboot the computer. If I add a DAC, I also have to reboot the computer. This adds a minute or so to many A/B processes, making them far less useful. And just think, up till this OS update USB WAS plug and play! Now suddenly USB has reverted to Firewire rules - never plug anything in while the computer is up and running. Ah, just like the good old days...

Another more minor annoyance is that with every DAC I've tried some DSD 64x music files which used to play fine on Aurdirvana+ now cause it to spit out spurious noise (along with a loud midrange POP right before the noise begins).

AR-usbshit3.jpgOne final new little OS-inspired mystery - the PS Audio NuWave DSD DAC I reviewed recently now reverses the right and left channels on all DSD material it decodes, but WAV and AIFF play fine. That is a head-scratcher.

Of course anyone who fancies themselves smarter than I (of which there are many) will write in the comments "A person who upgrades anything during the first two months it is available is just asking for trouble." They're right of course. And if I weren't a professional early-adopter I'd follow that sage advice to the letter. But in the meantime, I get the pleasure of bitching about it and perhaps warning off someone about to travel down the same path...

comments powered by Disqus

Audiophile Review Sponsors